Ticket #487 (closed cage: fixed)

Opened 5 years ago

Last modified 4 years ago

[CAGE] 'vtable method' needs to go away

Reported by: cotto Owned by: coke
Priority: minor Milestone:
Component: docs Version:
Severity: low Keywords: newbie, docs, cage
Cc: jkeenan Language:
Patch status: Platform:

Description (last modified by cotto) (diff)

Much code and many comments refer to 'vtable methods'. This term is inaccurate and deprecated. In most cases, it should be replaced with 'vtable function'.

Attachments

tt487.vtable.method.instances.txt Download (11.1 KB) - added by jkeenan 5 years ago.
Results of grep -ni ':vtable.*:method' on repository
replace-vtable-method-stage1.patch Download (6.5 KB) - added by Aninhumer 5 years ago.
Changed patch to be from parrot/ root, added some other fixes I'd missed
replace-vtable-method-stage2.patch Download (5.8 KB) - added by Aninhumer 5 years ago.
Less certain about these fixes
replacing_vtable_method_with_vtable_function.patch Download (30.1 KB) - added by tcurtis 4 years ago.
Replaces "vtable method" with "vtable function" in most places(ignoring strings and actual code).

Change History

Changed 5 years ago by jkeenan

Results of grep -ni ':vtable.*:method' on repository

Changed 5 years ago by jkeenan

  • cc jkeenan added

cotto,

I have attached a 169-line file with the results of a grep -ni ':vtable.*:method' on the repository. Could you look it over and suggest a plan of attack? (i.e., if I were to just do a search-and-replace, where would it work and where would it be likely to break?)

Thank you very much.
kid51

Changed 5 years ago by cotto

  • keywords newbie, docs, cage added
  • description modified (diff)

jkeenan, That's not what this ticket is about. This ticket concerns the use of the English phrase "vtable method" in documentation and comments, not pir-level subs marked as both :vtable and :method.

Changed 5 years ago by cotto

  • description modified (diff)

(This was intended to be the last half of my previous comment, not an addition to the ticket's description.)

That said, I'm tagging this task as "newbie" since this would be a good way for someone to build familiarity with Parrot while helping to keep the docs fresh.

Changed 5 years ago by Aninhumer

I've grep'd docs/ for "vtable method" (case insensitive) and made quite a few edits, this first patch is all the ones I'm pretty sure about.

Changed 5 years ago by coke

On Wed, Jan 13, 2010 at 9:38 AM, Parrot <parrot-tickets@lists.parrot.org> wrote:
> Comment(by Aninhumer):
>
>  I've grep'd docs/ for "vtable method" (case insensitive) and made quite a
>  few edits, this first patch is all the ones I'm pretty sure about.

+1; this looks apply-able.

Changed 5 years ago by Aninhumer

Changed patch to be from parrot/ root, added some other fixes I'd missed

Changed 5 years ago by Aninhumer

Less certain about these fixes

Changed 4 years ago by tcurtis

Replaces "vtable method" with "vtable function" in most places(ignoring strings and actual code).

Changed 4 years ago by coke

  • owner set to coke

Changed 4 years ago by coke

  • status changed from new to closed
  • resolution set to fixed

Resolved in r45297.

Note: See TracTickets for help on using tickets.