Ticket #488 (closed bug: invalid)

Opened 6 years ago

Last modified 3 years ago

Parrot::Interpreter - cannot load PCT.pbc - cannot find PCT/Grammar.pbc

Reported by: szabgab Owned by: whiteknight
Priority: normal Milestone:
Component: embed/extend Version: trunk
Severity: medium Keywords:
Cc: jkeenan Language:
Patch status: Platform: linux

Description

Attached test script (to be placed in ext/Parrot-Embed/t) works if I run it when standing in the parrot directory

perl -I ext/Parrot-Embed/blib/lib -I ext/Parrot-Embed/blib/arch ext/Parrot-Embed/t/load_pct.t

but when any other directory (e.g. in ext/Parrot-Embed) then the call

perl -Iblib/lib -Iblib/arch t/load_pct.t

fails with

"load_bytecode" couldn't find file 'PCT/Grammar.pbc'
current instr.: 'parrot;PCT;__onload' pc 0 (PCT.pir:15)
called from Sub 'mypct' pc 0 (EVAL_1:2)

Attachments

load_pct.t Download (0.8 KB) - added by szabgab 6 years ago.
ext/Parrot-Embed/t/load_pct.t

Change History

Changed 6 years ago by szabgab

ext/Parrot-Embed/t/load_pct.t

Changed 4 years ago by jkeenan

  • cc jkeenan added
  • owner set to whiteknight
  • component changed from none to embed/extend
  • severity changed from high to medium

szabgab,

I have tried to reproduce your test failure, but I don't get very far. I don't see these directories: ext/Parrot-Embed/blib/lib ext/Parrot-Embed/blib/arch ... even after I've built ./parrot. In fact, I don't know how to run any of the tests in ext/Parrot-Embed/t/.

Can you update/advise?

Thank you very much.

kid51

Changed 3 years ago by whiteknight

  • status changed from new to closed
  • resolution set to invalid

Parrot::Embed is gone from the repo now. Last I heard, it was completely broken and would need a complete ground-up rewrite if we want that kind of functionality around still.

Changed 3 years ago by benabik

This issue has been linked to the big "Parrot::Embed is broken" ticket on github:  https://github.com/parrot/parrot-embed/issues/1

Please add notes to that ticket or open a new one in that repository with any further information.

Note: See TracTickets for help on using tickets.