Ticket #541 (closed bug: duplicate)

Opened 5 years ago

Last modified 5 years ago

r37927 segfaults on building lua

Reported by: protein_origami Owned by:
Priority: major Milestone:
Component: hll_interop Version:
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

I had this problem on parrot 1.0.0, and confirmed that I have the same problem in 37927. The lua (commit 56008066d68415d10dfbd97326654ed19c514372) build proceeds smoothly up until:

/usr/local/parrot/r37927/bin/parrot -o lua.pbc lua.pir make: *** [lua.pbc] Segmentation fault

Here's the stack trace:

(gdb) run lua.pir Starting program: /mnt/sda5/local/parrot/r37927/bin/parrot lua.pir [Thread debugging using libthread_db enabled] [New Thread 0xb77e06b0 (LWP 6455)]

Program received signal SIGSEGV, Segmentation fault. [Switching to Thread 0xb77e06b0 (LWP 6455)] 0xb7eaf0da in make_pmc_const (interp=0x804f040, r=0x855e550)

at compilers/imcc/pbc.c:1802

1802 PMC * const _class = interp->vtables[r->pmc_type]->pmc_class; (gdb) where #0 0xb7eaf0da in make_pmc_const (interp=0x804f040, r=0x855e550)

at compilers/imcc/pbc.c:1802

#1 0xb7eaf353 in add_1_const (interp=0x804f040, r=0x855e550)

at compilers/imcc/pbc.c:1865

#2 0xb7eaf484 in constant_folding (interp=0x804f040, unit=0x8556f88)

at compilers/imcc/pbc.c:1903

#3 0xb7eaf696 in e_pbc_emit (interp=0x804f040, param_unused=0x0,

unit=0x8556f88, ins=0x8557140) at compilers/imcc/pbc.c:2130

#4 0xb7e9fcf0 in emit_flush (interp=0x804f040, param=0x0, unit=0x8556f88)

at compilers/imcc/instructions.c:908

#5 0xb7e99fde in imc_compile_unit (interp=0x804f040, unit=0x8556f88)

at compilers/imcc/imc.c:123

#6 0xb7e9a048 in imc_close_unit (interp=0x804f040, unit=0x8556f88)

at compilers/imcc/imc.c:230

#7 0xb7e8e7f1 in yyparse (yyscanner=0x81251c0, interp=0x804f040)

at compilers/imcc/imcc.y:1116

#8 0xb7e9a42e in compile_to_bytecode (interp=0x804f040,

sourcefile=0xbfd74765 "lua.pir", output_file=0x0) at compilers/imcc/main.c:967

#9 0xb7e9b731 in imcc_run (interp=0x804f040, sourcefile=0xbfd74765 "lua.pir",

argc=1, argv=0xbfd73398) at compilers/imcc/main.c:1066

#10 0x080488f8 in main (argc=1, argv=0xbfd73398) at src/main.c:61

Change History

Changed 5 years ago by jkeenan

See also TT #643.

Changed 5 years ago by jkeenan

  • component changed from none to hll_interop

Changed 5 years ago by whiteknight

  • status changed from new to closed
  • resolution set to duplicate

closing this ticket as a duplicate of #643.

Note: See TracTickets for help on using tickets.