Ticket #63 (closed bug: fixed)

Opened 6 years ago

Last modified 6 years ago

Failure in t/op/string_cclass.t

Reported by: moritz Owned by: NotFound
Priority: normal Milestone:
Component: none Version: trunk
Severity: medium Keywords:
Cc: Language:
Patch status: Platform: linux

Description

Parrot r34053 on i386 GNU/Linux fails one test:

t/op/string_cclass....7/11 # Failed test 'unicode is_cclass whitespace' # at t/op/string_cclass.t line 320. # Exited with error code: 2 # Received: # error:imcc:The opcode 'set_s_s_ki' (set<3>) was not found. Check the type and number of the arguments # in file '/home/moritz/src/parrot/t/op/string_cclass_7.pir' line 12 # # Expected: # 11111111111111111111111111 # t/op/string_cclass....11/11 # Looks like you failed 1 test of 11. t/op/string_cclass.... Dubious, test returned 1 (wstat 256, 0x100)

Failed 1/11 subtests

Change History

in reply to: ↑ description   Changed 6 years ago by jkeenan

Replying to moritz:

Parrot r34053 on i386 GNU/Linux fails one test: t/op/string_cclass....7/11 # Failed test 'unicode is_cclass whitespace' # at t/op/string_cclass.t line 320. # Exited with error code: 2 # Received: # error:imcc:The opcode 'set_s_s_ki' (set<3>) was not found. Check the type and number of the arguments # in file '/home/moritz/src/parrot/t/op/string_cclass_7.pir' line 12 # # Expected: # 11111111111111111111111111 #

Moritz:

I cannot reproduce this failure on Linux/Intel. On PPC/Darwin, the test is skipped:

ok 7 # SKIP unicode support unavailable

  Changed 6 years ago by NotFound

I fixed the problem in r34074 but failed, and later forget, to update the ticket.

  Changed 6 years ago by NotFound

  • status changed from new to assigned
  • owner set to NotFound

  Changed 6 years ago by NotFound

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.