Ticket #634 (closed bug: fixed)

Opened 6 years ago

Last modified 6 years ago

Docs to html incorrect in pdd07_codingstd.pod

Reported by: mikehh Owned by:
Priority: normal Milestone:
Component: docs Version: trunk
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

Problem with html in docs/html/docs/ppds/pdd07_codingstd.pod.html

C<Interp* foo> becomes <code>Interp *foo</code>

In pdd07_codingstd.pod (lines 155-158)

=item *

Pointer types should be written with separation between the star and the base
type, e.g. C<Interp *foo>, but not C<Interp* foo>.

generates in pdd07_codingstd.pod.html (line 146)

<li>Pointer types should be written with separation between the star and the base type, e.g. <code>Interp *foo</code>, but not <code>Interp *foo</code>.</li>

I think the problem is at line 217 of POD2HTML.pm

        # Tidy up the C reference *s.
        $text =~ s|\b\s*\*\s+\b| \*|gs;

Change History

in reply to: ↑ description   Changed 6 years ago by jkeenan

Replying to mikehh:

I spent > 2 hours with this problem this evening. But my efforts came to naught. Which confirms what I've thought for > 2 years: everything under lib/Parrot/Docs is inheritance-hell. I found it impossible to set up a simple test in which I would write a small .pod file with the string in question and then run it through the Parrot-specific version of pod2html to observe the results and debug.

  Changed 6 years ago by allison

  • status changed from new to closed
  • resolution set to fixed

Agreed, we can skip sanitizing the documentation here. Where the C *'s are wrong in the source we should fix the source, not try to hide it in the generated HTML.

Offending formatting code removed in r38969.

Note: See TracTickets for help on using tickets.