Ticket #673 (closed bug: wontfix)

Opened 5 years ago

Last modified 4 years ago

Parrot 1.1.0 build on OS X with Fink ICU package

Reported by: urkle Owned by:
Priority: normal Milestone:
Component: configure Version: 1.1.0
Severity: medium Keywords:
Cc: jkeenan Language:
Patch status: Platform: darwin

Description

On Mac OS X Leopard, the system provides ICU libraries (from Apple), however, they don't provide the headers (odd?). So, Fink provides an icu-devel package that includes the headers.. The issue is, the headers are locate in

/sw/include/unicode

and the libraries are in

/usr/lib

and the shared files are in

/usr/share/icu

You can see how this will cause lots of confusion. The icu-config provided by the fink package sets the CFLAGS correctly with a -I/sw/include, however parrot doesn't seem to use that at all.. So I do this

perl Configure.pl --icuheaders=/usr/include --icushared=/usr/lib

And configure detects ICU, but it doesn't build correctly. there are frequent errors where I have to manually patch config files and make files because "/usr/lib" is added directly to the LDFLAGS without the preceding -L.

I don't recall having this issue with Parrot 1.0.0 on OS X.

Now, if I "symlink" the unicode directory OVER to /usr/include, everything builds fine without the need to pass any arguments to Configure.pl

Change History

Changed 4 years ago by jkeenan

  • cc jkeenan added

Changed 4 years ago by dukeleto

  • status changed from new to closed
  • resolution set to wontfix

Parrot 1.1.0 is a quite old, unsupported development version. We will gladly accepted new tickets if this problem still occurs in newer versions of Parrot.

Note: See TracTickets for help on using tickets.