Ticket #676 (new cage)
Fix namespace pollution
|Reported by:||Infinoid||Owned by:||whiteknight|
There are many global symbols we're exporting which don't have a "Parrot_" prefix. This list might vary a bit depending on OS and platform, but I'll attach my current list. By my count, there are currently 182 functions and 1 variable (PMCNULL) exported by default.
I think the idea is that these functions should be renamed from "funcname" to "Parrot_funcname", and some #defines should be left behind (inside an #ifdef PARROT_IN_CORE) so we don't need to fix up all the callers (and therefore, don't need a deprecation cycle).
I think it would be a good idea to make headerizer do this for us.