Ticket #736 (closed patch: duplicate)

Opened 5 years ago

Last modified 5 years ago

[PATCH] icu-config emits prefix with extra newline

Reported by: hv Owned by: Infinoid
Priority: normal Milestone:
Component: configure Version: 1.2.0
Severity: low Keywords: icu-config
Cc: Language:
Patch status: new Platform: linux

Description

Having fetched, built and installed latest release icu library (configured with './runConfigureICU Linux --prefix=/opt/icu-4.2.0.1'), I then tried to configure parrot-1.2.0 with '/opt/perl-5.10.0/bin/perl Configure.pl --prefix=/opt/parrot-1.2.0 --icu-config=/opt/icu-4.2.0.1/bin/icu-config'. The result was an attempt to handle a path with a trailing newline, because of this:

zen% /opt/icu-4.2.0.1/bin/icu-config --prefix
/opt/icu-4.2.0.1

zen%

.. as a result of which parrot's configure emitted:

auto::icu -           Is ICU installed...Unsuccessful stat on filename containing newline at config/auto/icu.pm line 331.
Unsuccessful stat on filename containing newline at config/auto/icu.pm line 336.
...........................not found.

I'm not sure what guarantees *-config scripts are supposed to offer about output, but the to-be-attached patch works for me.

Hugo

Attachments

config-icu.patch Download (378 bytes) - added by hv 5 years ago.
chop all trailing newlines on icu prefix

Change History

Changed 5 years ago by hv

chop all trailing newlines on icu prefix

  Changed 5 years ago by Infinoid

  • owner set to Infinoid

Hi! Thanks very much for the patch.

I think this is a duplicate of ticket #723, which had a similar patch and got applied a few days ago. So it should be fixed in the latest trunk revision. If you want to verify the fix, you can try a subversion checkout of parrot's "trunk" branch. If it is not fixed, please reply to this ticket and I will reopen it.

Thanks!

Mark

follow-up: ↓ 3   Changed 5 years ago by Infinoid

  • status changed from new to closed
  • resolution set to duplicate

in reply to: ↑ 2   Changed 5 years ago by hv

Replying to Infinoid: Ah yes, that looks fine (though relying on two chomps in different places in the code seems a little fragile).

Thanks,

Hugo

Note: See TracTickets for help on using tickets.