Ticket #785 (closed bug: worksforme)

Opened 11 years ago

Last modified 11 years ago

"hello world" nqp fails when run with installed parrot

Reported by: coke Owned by:
Priority: normal Milestone:
Component: install Version: 1.3.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

The following snippet of NQP -

my $foo := "hello world";
say($foo);

works fine when run out of the build dir like so:

./parrot compilers/nqp/nqp.pbc foo.nqp

But fails when run against an installed copy of the same parrot:

~/bird/bin/parrot ~/bird/lib/parrot/1.3.0-devel/languages/nqp/nqp.pbc foo.nqp
No applicable methods.

current instr.: 'parrot;P6metaclass;register' pc 644 (runtime/parrot/library/P6object.pir:426)
called from Sub 'parrot;P6object;onload' pc 34 (runtime/parrot/library/P6object.pir:86)
called from Sub 'parrot;PGE;Match;' pc 0 (compilers/pge/PGE/Match.pir:17)
called from Sub 'parrot;NQP;Compiler;__onload' pc 0 (nqp.pir:7)
called from Sub 'parrot;NQP;Compiler;main' pc -1 ((unknown file):-1)

Change History

Changed 11 years ago by NotFound

Cannot reproduce this. Following irc suggestions I built and installed parrot with the default configutation, then built and installed in directory on my home. Both run the nqp program without any problem. Platform is linux i386

Changed 11 years ago by jkeenan

  • component changed from none to install

Changed 11 years ago by allison

I also can't reproduce this on Ubuntu 9.04, even when I remove the build directory.

On Mac OS X, I have no trouble when the build directory is in place, but when I remove the build directory I get an error that seems to be unrelated to the one Coke is getting but they might both be caused by the same root problem:

allison@ezet:~/boojum$ ~/boojum/bin/parrot ~/boojum/lib/parrot/1.3.0-devel/languages/nqp/nqp.pbc hello.nqp 
src/io/api.c:205: failed assertion 'pmc'
Backtrace - Obtained 20 stack frames (max trace depth is 32).
  Parrot_do_check_events
    Parrot_confess
      Parrot_io_flush
        Parrot_ex_add_c_handler
          Parrot_ex_throw_from_c
            Parrot_ex_throw_from_op_args
              Parrot_Iterator_init
                Parrot_default_thaw
                  Parrot_stat_info_string
                    Parrot_stat_info_string
                      Parrot_stat_info_string
                        Parrot_stat_info_string
                          Parrot_thaw
                            Parrot_set_config_hash_internal
                              Parrot_set_config_hash_internal
                                Parrot_set_config_hash_internal
                                  make_interpreter
                                    Parrot_new
                                      start
                                        start
Abort trap

Changed 11 years ago by allison

And annoyingly, the problem disappears when running under gdb.

Changed 11 years ago by coke

  • status changed from new to closed
  • resolution set to worksforme

I can't duplicate this with trunk (2.1.0+)

Note: See TracTickets for help on using tickets.