Ticket #889 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

parrot_debugger throws an exception when deleting a breakpoint

Reported by: dukeleto Owned by: dukeleto
Priority: normal Milestone:
Component: none Version: 1.4.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

./parrot_debugger t/tools/parrot_debugger.t.20.pasm

Parrot 1.4.0-devel Debugger

Please note: the debugger is currently under reconstruction

(pdb) b

Breakpoint 1 at pos 0

(pdb) d 1

Bus error

Attachments

parrot_debugger.t.20.pasm Download (16 bytes) - added by dukeleto 5 years ago.
A simple one line PASM source file to exhibit the problem
parrot_debugger.t.20.2.pasm Download (16 bytes) - added by dukeleto 5 years ago.
A simple one line PASM source file to exhibit the problem

Change History

Changed 5 years ago by dukeleto

A simple one line PASM source file to exhibit the problem

Changed 5 years ago by dukeleto

A simple one line PASM source file to exhibit the problem

Changed 5 years ago by dukeleto

  • owner set to dukeleto
  • status changed from new to assigned

Changed 5 years ago by dukeleto

  • summary changed from parrot_debugger generates a Bus error when deleting a breakpoint to parrot_debugger throws an exception when deleting a breakpoint

Tests for this were added in r40333 as well as turning the Bus Error into an exception that is thrown with the message "No file loaded".

The issue is that interp->pdb->file is NULL. This is the source of listing the file not working as well.

Changed 5 years ago by dukeleto

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.