Ticket #934 (closed bug: worksforme)

Opened 5 years ago

Last modified 4 years ago

PGE build leads to assertion failure on MacOS X?

Reported by: moritz Owned by:
Priority: normal Milestone:
Component: build Version: 1.5.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform: darwin

Description

masak reports (but can't do so directly, because trac does an infinite redirect loop for him) that r40656 broke the build on MacOS X:

[...]
gmake[1]: Entering directory `/Users/masak/work/hobbies/parrot/compilers/pge'
perl -MExtUtils::Command -e rm_f PGE.pbc ../../runtime/parrot/library/PGE.pbc
perl -e "" >PGE/builtins_gen.pir
../../parrot -o PGE.pbc --output-pbc PGE.pir
../../parrot ../../runtime/parrot/library/PGE/Perl6Grammar.pir --output=PGE/builtins_gen.pir PGE/builtins.pg
src/string/api.c:2568: failed assertion '(s)->encoding'
Backtrace - Obtained 32 stack frames (max trace depth is 32).
0 libparrot.dylib 0x00414abd Parrot_do_check_events + 173
1 libparrot.dylib 0x00414c27 Parrot_confess + 151
2 libparrot.dylib 0x003a52e2 Parrot_str_to_hashval + 130
3 libparrot.dylib 0x00428238 Parrot_set_config_hash_internal + 1400
4 libparrot.dylib 0x00429e7d parrot_hash_get_bucket + 237
5 libparrot.dylib 0x0057662f Parrot_FixedStringArray_get_isa + 5663
6 libparrot.dylib 0x0047365b Parrot_mmd_cache_destroy + 208107
7 libparrot.dylib 0x005ca63b Parrot_PCCMETHOD_Test_get_isa + 2331
8 libparrot.dylib 0x0048536a pmc_new_init + 250
9 libparrot.dylib 0x00473f07 Parrot_mmd_cache_destroy + 210327
10 libparrot.dylib 0x0047427c Parrot_oo_get_class_str + 300
11 libparrot.dylib 0x005866d2 Parrot_Capture_get_isa + 12114
12 libparrot.dylib 0x005b4d67 Parrot_NameSpace_get_isa + 64727
13 libparrot.dylib 0x005a06f7 Parrot_MultiSub_get_isa + 4295
14 libparrot.dylib 0x004272f4 Parrot_set_global + 100
15 libparrot.dylib 0x003d89b5 Parrot_str_from_int + 202085
16 libparrot.dylib 0x00488004 enable_event_checking + 1508
17 libparrot.dylib 0x004870a4 gc_unregister_pmc + 5204
18 libparrot.dylib 0x00433bd5 new_runloop_jump_point + 389
19 libparrot.dylib 0x00433f19 new_runloop_jump_point + 1225
20 libparrot.dylib 0x00434d6a Parrot_runops_fromc_args + 186
21 libparrot.dylib 0x004769da Parrot_ComposeRole + 3418
22 libparrot.dylib 0x00476bae Parrot_ComposeRole + 3886
23 libparrot.dylib 0x00476f97 do_sub_pragmas + 407
24 libparrot.dylib 0x0047e0f8 PackFile_Annotations_add_entry + 2184
25 libparrot.dylib 0x0047e1a0 PackFile_Annotations_add_entry + 2352
26 libparrot.dylib 0x0047e7b4 Parrot_load_bytecode + 500
27 libparrot.dylib 0x003a7700 Parrot_str_from_int + 688
28 libparrot.dylib 0x00488004 enable_event_checking + 1508
29 libparrot.dylib 0x004870a4 gc_unregister_pmc + 5204
30 libparrot.dylib 0x00433bd5 new_runloop_jump_point + 389
31 libparrot.dylib 0x00433f19 new_runloop_jump_point + 1225
gmake[1]: *** [PGE.pbc] Abort trap
gmake[1]: *** Deleting file `PGE.pbc'
gmake[1]: Leaving directory `/Users/masak/work/hobbies/parrot/compilers/pge'
make: *** [compilers.dummy] Error 2

Change History

follow-up: ↓ 2   Changed 5 years ago by jkeenan

  • platform set to darwin
  • component changed from none to build

I had no problems building or testing Parrot on Mac OS X 10.4, Darwin/PPC, at the slightly later revision r40664.

kid51

in reply to: ↑ 1   Changed 5 years ago by jkeenan

Replying to jkeenan:

I had no problems building or testing Parrot on Mac OS X 10.4, Darwin/PPC, at the slightly later revision r40664. kid51

I should have added: See  this Smolder report.

  Changed 5 years ago by dukeleto

Is this problem persisting? I cannot reproduce it on OS X 10.5.8 powerpc or x86.

  Changed 5 years ago by jkeenan

Moritz/Masak: Can we get an update on this problem?

If no one can reproduce it I believe we should close the ticket.

kid51

  Changed 4 years ago by nwellnhof

  • status changed from new to closed
  • resolution set to worksforme

I think we can close this ticket as unreproducible.

Note: See TracTickets for help on using tickets.