Ticket #968 (closed bug: fixed)
Rename PObj_active_destroy_foo to PObj_custom_destroy_foo
|Reported by:||jrtayloriv||Owned by:||jkeenan|
Earlier, in #parrot I brought up the suggestion that we rename the macros/flags whose names contain "active_destroy" to "custom_destroy".
The function of setting the PObj_active_destroy_FLAG is to say that the the PMC has a custom destroy() function, and there is no reason not to have the name tell us this.
Also, the analogous set of flags/macros for the mark() VTABLE already ARE called PObj_custom_mark_foo, rather than PObj_active_mark_foo. These macros should be named similarly since they serve exactly the same purpose, for the two different functions (i.e. they say "I have a custom mark()/destroy() function").
I recommend globally replacing active_destroy with custom_destroy. Any reasons why we shouldn't?