Ticket #977 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

parrot_config returns with an error about "Invalid Charset"

Reported by: treed Owned by:
Priority: critical Milestone:
Component: tools Version: trunk
Severity: medium Keywords:
Cc: Language:
Patch status: Platform: mac

Description

Attempting to run parrot_config with any (or no) arguments, I get the following output (delimited by --):

--

Invalid charset number '1768057203' specified --

I'm marking this as Platform:mac, because no one else seems to be having this problem. I don't know positively that other mac users experience it either.

Attachments

perlv Download (2.6 KB) - added by treed 5 years ago.
perl -V

Change History

Changed 5 years ago by treed

That second -- should have been on the next line.

Changed 5 years ago by dukeleto

I cannot build parrot trunk on darwin right now, I get a similar error about Invalid Charset:  http://gist.github.com/181220

I just updated to perl 5.10.1 last night, which is suspicious. The perl -V for each perl, the first one which does not work with parrot, are here:  http://nopaste.snit.ch/17819

Changed 5 years ago by dukeleto

  • priority changed from normal to critical

Changed 5 years ago by treed

perl -V

Changed 5 years ago by treed

Just attached my perl -V. Notably, I have not mucked with my Perl at all recently.

Changed 5 years ago by dukeleto

I made another ticket, #979, since my issue is not quite the same. I can reproduce it without perl 5.10.1, so that does not seem to be the issue.

I wonder if you are getting an error duing compilation that you didn't notice? Do you have a correctly generated PCT.pbc when you build?

Changed 5 years ago by treed

I'd have to watch the compile to determine if there are errors, rather than hitting the button and getting a drink. :-)

I think I'll have time to do that tomorrow.

However, I can say that I ran make test yesterday, and it returned OK.

Changed 5 years ago by treed

Oh, also, if hardcode build_dir into my Rakefile for Cardinal, cardinal builds and tests fine. (Other than the usual three errors we've been seeing for a while.)

So this error really does seem to be just parrot_config.

Changed 5 years ago by jkeenan

  • owner set to dukeleto
  • component changed from none to tools

Changed 5 years ago by dukeleto

I am pretty sure this error arises when you are using your installed parrot when you shouldn't be.

Changed 5 years ago by dukeleto

Can you remove your installed parrot and verify that this still occurs?

Changed 5 years ago by treed

I am specifically trying to use my installed parrot.

Changed 5 years ago by dukeleto

  • owner changed from dukeleto to jkeenan

Changed 5 years ago by jkeenan

  • owner jkeenan deleted

I have no expertise in the area, so I'm reassigning ticket to no one.

Changed 5 years ago by dukeleto

Can you attach the output of running valgrind on parrot_config ?

Something like:

valgrind --show-reachable=yes --dsymutil=yes ./parrot_config

The --dsymutil flag is necessary on darwin. If you don't have dylib's, then you don't need it.

Changed 5 years ago by dukeleto

There is now a script in tools/ to run valgrind correctly on darwin. Now you can run:

./tools/dev/vgp_darwin ./parrot_config

Changed 5 years ago by treed

Seems to have been fixed sometime in the last month.

Changed 5 years ago by cotto

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.