Ticket #979 (closed bug: invalid)

Opened 5 years ago

Last modified 5 years ago

Invalid charset number '8' on darwin during PCT.pbc bytecode generation

Reported by: dukeleto Owned by:
Priority: critical Milestone: 1.6
Component: build Version: 1.5.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform: darwin

Description (last modified by dukeleto) (diff)

during a normal "make" on darwin

gmake -C compilers/pct
gmake[1]: Entering directory `/Users/leto/work/parrot-git-svn/compilers/pct'
../../parrot -o ../../runtime/parrot/library/PCT.pbc --output-pbc PCT.pir

Invalid charset number '8' specified
gmake[1]: *** [../../runtime/parrot/library/PCT.pbc] Error 1
gmake[1]: Leaving directory `/Users/leto/work/parrot-git-svn/compilers/pct'
make: *** [compilers.dummy] Error 2

Attachments

build_parrot.sh Download (67 bytes) - added by dukeleto 5 years ago.
Script to build parrot and exit with exit code of make

Change History

Changed 5 years ago by dukeleto

  • description modified (diff)

Changed 5 years ago by dukeleto

I have bisected this to r40958 (Merge context_pmc3 branch into trunk), bisect log availale at  http://nopaste.snit.ch/17828 .

To do the bisection I did

   git bisect start head 77b3917 -- # tag for release 1.5.0, avoids testing a merge base
   git bisect good # i knew that 1.5.0 worked, and tested separately as well  
   git bisect run /tmp/build_parrot.sh

I have attached build_parrot.sh .

Changed 5 years ago by dukeleto

Script to build parrot and exit with exit code of make

Changed 5 years ago by dukeleto

This turned out to be /usr/local/lib/libparrot.dylib being using instead of the newly build one in blib/lib. rm'ing my installed parrot was sufficient to get me compiling again. I think a loud warning should be added to Configure.pl about conflicts with installed parrots, or the order of the library path should be correct.

Changed 5 years ago by dukeleto

This ticket is related to  http://rt.perl.org/rt3//Ticket/Display.html?id=52288 . The problem is that config/inter/libparrot.pm doesn't know that dylib the extension that darwin uses, so it doesn't warn about an installed parrot.

Changed 5 years ago by dukeleto

  • status changed from new to closed
  • resolution set to invalid

config/inter/libparrot.pm has learned about darwin as of r41022

Note: See TracTickets for help on using tickets.