Changes between Version 5 and Version 6 of PackfileTasklist

Show
Ignore:
Timestamp:
12/30/10 15:38:31 (4 years ago)
Author:
whiteknight
Comment:

+more tasks

Legend:

Unmodified
Added
Removed
Modified
  • PackfileTasklist

    v5 v6  
    1616 - Parrot_load_language is an HLL function. it belongs in src/hll.c or similar, not in src/packfile/api.c 
    1717   - This might make a good gci task. 
     18 - Move pragma-related and sub-related functions into a new file: src/packfile/execute.c 
     19 - Move Code for different kinds of segments into separate files: src/packfile/annotation_segment.c, src/packfile/debug_segment.c, src/packfile/constant_segment.c, etc 
     20 - Public packfile functions in src/packfile/api.c should be named Parrot_pf_*. Probably best to do this task after unrelated items are removed from that file first. 
     21 - Parrot_load_language should be moved/renamed to src/hll.c:Parrot_hll_load 
    1822 
    1923= Sub Pragmas =