Version 5 (modified by whiteknight, 5 years ago)

cleanup. Add note about the need to properly encapsulate things.

General Cleanup

* Convert 'sprintf' to 'snprintf' where possible. See RT #39117.

* Properly encapsulate strings system so that only files and routines in src/strings/* directly access fields in the STRING structure

NFG Refactor

* Implement NFG string format.

Completed

* Change the name of runtime function 'const_string' so it's more clearly distinct from compile-time macro 'CONST_STRING'. (allison, r36230)